В IOS версии 12.1(6) и выше защитный маршрут генерируется автоматически по умолчанию. Если по какой-либо причине вы не хотите использовать защитный маршрут, можно настроить следующие команды для router ospf : [no] discard-route internal или [no] discard-route external Примечание о расчете метрики суммарного адреса. Стандарт RFC 1583 применяется для расчета метрик суммарных маршрутов на основе минимальных метрик путей компонентов. Стандарт RFC 2178 (больше не используется, заменен на RFC 2328 ) изменял указанный метод расчета метрик для суммарных маршрутов, стоимость суммированного маршрута определялась максимальной стоимостью компонента этого маршрута.
До выхода IOS 12.0 продукты Cisco соответствовали актуальному на тот момент стандарту RFC 1583 . С выходом IOS 12.0 компания Cisco изменила режим работы OSPF в соответствии с новым стандартом RFC 2328 . В результате появилась вероятность субоптимальной маршрутизации в случае, если код всех ABR в области не был обновлен одновременно. Для решения этой потенциальной проблемы в OSPF-конфигурацию Cisco IOS была добавлена команда, позволяющая выборочно отключать совместимость с RFC 2328. Новая команда конфигурации используется после команды router ospf и имеет следующий синтаксис: [no] compatible rfc1583 Настройка по умолчанию — "совместим с RFC 1583 ". Команда доступна в следующих версиях IOS:
12.1(03)DC 12.1(03)DB 12.001(001.003) - 12.1 Mainline 12.1(01.03)T - 12.1 T-Train 12.000(010.004) - 12.0 Mainline 12.1(01.03)E - 12.1 E-Train 12.1(01.03)EC 12.0(10.05)W05(18.00.10) 12.0(10.05)SC Суммирование внешних маршрутов Суммирование внешних маршрутов применяется к маршрутам, введенным в OSPF с помощью перераспределения. Убедитесь, что внешние суммируемые диапазоны непрерывны. Суммирование перекрывающихся диапазонов двух разных маршрутов может привести к отправке пакетов не по назначению. Суммирование выполняется с помощью следующей подкоманды router ospf : summary-address ip-address mask