Siemens — 3. Обмен данными

Обмен данными 3.2 Коммуникационные услуги Подробная информация Подробные описания отдельных блоков вы найдете в Справочном руководстве Системное программное обеспечение для S7-300/400. Системные и стандартные функции . 3.2.10.3 Открытый обмен данными через Industrial Ethernet Предпосылки • STEP 7 V5.3 + Servicepack 1 или выше Функциональные возможности CPU со встроенным интерфейсом и с программой ПЗУ, начиная с версии V2.3.0 или V2.4.0, поддерживают функциональные возможности открытого обмена данными через Industrial Ethernet (сокращенно: открытые IE-коммуникации ) Для открытых IE-коммуникаций имеются в распоряжении следующие услуги:

• Протоколы, ориентированные на соединения – TCP в соответствии с RFC 793, тип соединения B#16#01, начиная с программы ПЗУ V2.3.0 – TCP в соответствии с RFC 793, тип соединения B#16#11, начиная с программы ПЗУ V2.4.0 – ISO-on-TCP в соответствии с RFC 1006, начиная с программы ПЗУ V2.4.0 • Протоколы без установления соединения – UDP в соответствии с RFC 768, начиная с программы ПЗУ V2.4.0 Свойства протоколов передачи данных При передаче данных различают следующие протоколы: • Протоколы, ориентированные на соединения: Перед передачей данных они создают (логическое) соединение с партнером по обмену данными и, если необходимо, снова разрывают это соединение, после завершения передачи.

Протоколы, ориентированные на соединения, используются, если при передаче данных особенно важна надежность. Через физическую линию можно, как правило, осуществить несколько логических соединений. У FB для открытого обмена данными через Industrial Ethernet поддерживаются следующие протоколы, ориентированные на соединения: – TCP в соответствии с RFC 793 (типы соединений B#16#01 и B#16#11) – ISO-on-TCP в соответствии с RFC 1006 (тип соединения B#16#12) • Протоколы без установления соединения: Они работают без соединения. Отпадают также установление и завершение соединения с удаленным партнером.

Протоколы без установления соединения передают данные без квитирования и, таким образом, не обеспечивают надежности для удаленного партнера. У FB для открытого обмена данными через Industrial Ethernet поддерживается следующий протокол без установления соединения: – UDP в соответствии с RFC 768 (тип соединения B#16#13) SIMATIC S7-300 CPU 31xC and CPU 31x, Technical Specifications 3-26 Manual, 12/2006 , A5E00105475-07