cisco · Catalyst 9000 Series Switches · 12 стр.

Cisco Catalyst 9000 Series: BGP EVPN VXLAN Overview and Guide (EN)

Оригинальное название: Cisco Catalyst 9000 Series: BGP EVPN VXLAN Overview and Guide

Читать онлайн

Похожие инструкции

Содержание

Текст документа

The Evolution of BGP EVPN VXLAN

BGP EVPN VXLAN Overview Restrictions for BGP EVPN VXLAN, on page 1 BGP EVPN VXLAN, on page 1 The Evolution of BGP EVPN VXLAN, on page 1 Benefits of Deploying Overlay-Underlay Architecture using BGP EVPN VXLAN, on page 2 Fundamental Concepts of BGP EVPN VXLAN, on page 2 Restrictions for BGP EVPN VXLAN BGP EVPN VXLAN does not support Generic Routing Encapsulation (GRE) in the underlay. BGP EVPN VXLAN BGP EVPN VXLAN is a campus network solution for Cisco Catalyst 9000 Series Switches running Cisco IOS XE software. This solution is a result of ratified IETF RFC specifications RFC 7432 and RFC 8365 supporting BGP EVPN control plane with RFC 7348 VXLAN data-plane.

In addition, multiple other BGP EVPN RFCs and Internet drafts submitted by the BGP Enabled ServicesS (bess 1 ) workgroup are supported. It is designed to provide a unified overlay network solution and also address the challenges and drawbacks of existing technologies. This chapter provides a background for the evolution of the solution and covers conceptual information and basic terminology that is required to understand BGP EVPN VXLAN. Later chapters of this configuration guide cover information about configuration, implementation, functionalities, and troubleshooting BGP EVPN VXLAN.

The Evolution of BGP EVPN VXLAN Traditionally, VLANs have been the standard method for providing network segmentation in campus networks. VLANs use loop prevention techniques such as Spanning Tree Protocol (STP), which impose restrictions on network design and resiliency. Further, there is a limitation with the number of VLANs that can be used to address layer 2 segments (4094 VLANs). Therefore, VLANs are a limiting factor for IT departments and cloud providers who build large and complex campus networks. VXLAN is designed to overcome the inherent limitations of VLANs and STP.

It is a proposed IETF standard [ RFC 7348 ] to provide the same Ethernet Layer 2 network services as VLANs do, but with greater flexibility. BGP EVPN VXLAN Overview 1

Стр. 1

Fundamental Concepts of BGP EVPN VXLAN

Functionally, VXLAN is a MAC-in-UDP encapsulation protocol that runs as a virtual overlay on an existing Layer 3 network. However, VXLAN by itself does not provide optimal switching and routing capabilities in a network because it uses a “flood and learn” mechanism that limits scalability. "Flood and learn" mechanism is where the host’s information is flooded across the network for it to be reachable. To provide optimal switching and routing capabilities, a VXLAN overlay requires: • An underlying transport network that performs data plane forwarding to allow unicast communication between end points connected to the fabric.

• A control plane that is capable of distributing Layer 2 and Layer 3 host reachability information across the network. To meet these additional requirements, Internet drafts submitted by the bess workgroup ( draft-ietf-bess-evpn-overlay-12 ) proposed MP-BGP to carry Layer 2 MAC and Layer 3 IP information simultaneously. MP-BGP incorporates Network Layer Reachability Information (NLRI) to achieve this. With MAC and IP information available together for forwarding decisions, routing and switching within a network is optimized. This also minimizes the use of the conventional "flood and learn" mechanism used by VXLAN and allows for scalability in the fabric.

EVPN is the extension that allows BGP to transport Layer 2 MAC and Layer 3 IP information. This deployment is called a BGP EVPN VXLAN fabric (also referred to as VXLAN fabric). Benefits of Deploying Overlay-Underlay Architecture using BGP EVPN VXLAN Deploying an overlay-underlay architecture using BGP EVPN VXLAN provides the following advantages: • Scalability — VXLAN provides Layer 2 connectivity that allows for infrastructure that can scale to 16 million tenant networks. It overcomes the 4094-segment limitation of VLANs. This is necessary to address today’s multi-tenant cloud requirements.

• Flexibility — VXLAN allows workloads to be placed anywhere, along with the traffic separation required, in a multitenant environment. The traffic separation is done by network segmentation using VXLAN segment IDs or VXLAN network identifiers (VNIs). Workloads for a tenant can be distributed across different physical devices but they are identified by their respective Layer 2 VNI or Layer 3 VNI. • Mobility — Virtual machines can be moved from one location to another without updating spine switch tables. This is because entities within the same tenant VXLAN network retain the same VXLAN segment ID, regardless of their location.

Fundamental Concepts of BGP EVPN VXLAN This section provides information about the various fundamental concepts and terminologies that are involved in the working of BGP EVPN VXLAN. BGP EVPN VXLAN Overview Benefits of Deploying Overlay-Underlay Architecture using BGP EVPN VXLAN BGP EVPN VXLAN Overview 2

Стр. 2

Virtual Tunnel End Points

VXLAN Overlay An overlay network is a virtual network that is built over an existing Layer 2 or Layer 3 network by forming a static or dynamic tunnel that runs on top of the physical network infrastructure. The existing Layer 2 or Layer 3 network is what forms the underlay and is covered further below in this chapter. When a data packet is sent through an overlay, the original packet or frame is packaged or encapsulated at a source edge device with an outer header and dispatched toward an appropriate destination edge device. The intermediate network devices forward the packet based on the outer header but are not aware of the data in the original packet.

At the destination edge device, the packet is decapsulated by stripping off the overlay header and then forwarded based on the actual data within. In the context of BGP EVPN VXLAN, VXLAN is used as the overlay technology to encapsulate the data packets and tunnel the traffic over a Layer 3 network. VXLAN creates a Layer 2 overlay network by using a MAC-in-UDP encapsulation. A VXLAN header is added to the original Layer 2 frame and it is then placed within a UDP-IP packet. A VXLAN overlay network is also called as a VXLAN segment. Only host devices and virtual machines within the same VXLAN segment can communicate with each other.

VXLAN Network Identifier Each VXLAN segment is identified through a 24-bit segment ID, termed the VXLAN network identifier. This ensures that up to 16 million VXLAN segments can be present within the same administrative domain. Virtual Tunnel End Points Every VXLAN segment has tunnel edge devices known as Virtual Tunnel End points (VTEPs). These devices sit at the edge of the VXLAN network and are responsible for creating instances of VXLAN tunnels, and for performing VXLAN encapsulation and decapsulation. A VTEP has a switch interface on the local LAN segment to support local endpoint communication through bridging, and an IP interface to interact with the transport IP network.

The IP interface has a unique IP address that identifies the VTEP on the transport IP network. The VTEP uses this IP address to encapsulate Ethernet frames and transmits the encapsulated packets to the transport network through the IP interface. A VTEP device also discovers the remote VTEPs for its VXLAN segments and learns remote MAC address-to-VTEP mappings through its IP interface. The following figure illustrates the working of an overlay VXLAN network connecting various VTEPs: BGP EVPN VXLAN Overview VXLAN Overlay BGP EVPN VXLAN Overview 3

Стр. 3

Underlay

Figure 1: Overlay VXLAN Network Overlay Multicast Overlay multicast is the method by which a overlay network forwards multicast traffic between various VTEPs present in the network. Tenant Routed Multicast (TRM) provides a mechanism to efficiently forward multicast traffic in a VXLAN overlay network. TRM is a BGP-EVPN based solution that enables multicast routing between sources and receivers connected on VTEPs in VXLAN fabric. Without TRM, the multicast traffic is sent as part of the underlay network in the form of BUM traffic either using underlay multicast or ingress replication methods.

This does not allow sources and receivers that are present across different subnets to communicate with each other. Using TRM, multicast communication is moved out of the BUM underlay traffic. This enables multicast communication in the overlay network irrespective of the subnet in which the source or the receiver resides. Underlay An underlay network is the physical network over which the virtual overlay network is established. Once the overlay network is defined along with the data-plane encapsulation, a method of transport is required to move the data across the physical network underneath. This method of transport is typically an underlay transport network, or simply the underlay.

In BGP EVPN VXLAN, the underlay Layer 3 network transports the VXLAN-encapsulated packets between the source and destination VTEPs and provides reachability between them. The VXLAN overlay and the underlying IP network between the VTEPs are independent of each other. BGP EVPN VXLAN Overview Overlay Multicast BGP EVPN VXLAN Overview 4

Стр. 4