Протоколы туннелирования (такие как GRE, IPsec и L2TP) также требуют места для размещения заголовков и трейлеров. Это также приводит к уменьшению фактического размера MTU исходящего интерфейса. В последующих разделах будет рассмотрена работа PMTUD для случаев, когда протокол туннелирования расположен где-то между двумя оконечными узлами. Из всех трех случаев, что были рассмотрены выше, данный случай является наиболее комплексным: он иллюстрирует все проблемы, которые были рассмотрены в других примерах. Что такое туннель?
Туннель – это расположенный на маршрутизаторе Cisco логический интерфейс, который предоставляет механизм для инкапсулирования пакетов-пассажиров (passenger packets) в транспортный протокол. Данный механизм предоставляет службы, которые позволяют реализовать схему инкапсуляции «точка – точка». Механизм туннелирования состоит из трех основных компонентов: транспортируемый протокол (AppleTalk, Banyan VINES, CLNS, DECnet, IP или IPX) транспортирующий протокол (один из протоколов инкапсуляции, приведенных ниже): GRE – многопротокольный транспортирующий (несущий) протокол Cisco. Дополнительные сведения см. в документах RFC 2784 и RFC 1701 . Туннели IP-in-IP – дополнительные сведения см.
в документе RFC 2003 . транспортный протокол – протокол, используемый для переноса инкапсулированного протокола Пакеты ниже иллюстрируют концепции IP-туннелирования, где GRE – протокол инкапсуляции, а IP – транспортный протокол. Транспортируемым протоколом также является протокол IP. В данном случае протокол IP является как транспортным, так и транспортируемым протоколом. Обычный пакет Туннельный пакет IP – транспортный протокол. GRE – протокол инкапсуляции. IP – транспортируемый протокол. В следующем примере показана инкапсуляция IP и DECnet как протоколов переноса с GRE в качестве носителя. Это иллюстрирует тот факт, что протокол несущей может инкапсулировать несколько протоколов переноса.
IP TCP Telnet IP GRE IP TCP Telnet