DELETE Request (To Delete the Configuration) Device:~# curl -i -k -X "DELETE" "https://10.85.116.30:443/restconf/data/Cisco-IOS-XE-native:native/logging/monitor/severity" \ > -H 'Content-Type: application/yang-data+json' \ > -H 'Accept: application/yang-data+json' \ > -u 'admin:admin' HTTP/1.1 204 No Content Server: nginx Date: Mon, 23 Apr 2018 15:26:05 GMT Content-Type: text/html Content-Length: 0 Connection: keep-alive Last-Modified: Mon, 23 Apr 2018 15:26:05 GMT Cache-Control: private, no-cache, must-revalidate, proxy-revalidate Etag: 1524-497165-473206 Pragma:
no-cache linux_host:~# Additional References for the RESTCONF Protocol Related Documents Standards and RFCs RESTCONF Protocol Additional References for the RESTCONF Protocol Related Topic Document Title YANG data models for various releases of IOS XE, IOS XR, and NX-OS platforms To access Cisco YANG models in a developer-friendly way, please clone the GitHub repository, and navigate to the vendor/cisco subdirectory. Models for various releases of IOS-XE, IOS-XR, and NX-OS platforms are available here. Standard/RFC Title RFC 6020 YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF) RFC 8040 RESTCONF Protocol RFC 8072 YANG Patch Media Type RESTCONF Protocol 30