cisco Model-Driven Telemetry — Additional References for Model-Driven Telemetry

Additional References for Model-Driven Telemetry Standards and RFCs Model-Driven Telemetry Additional References for Model-Driven Telemetry Command or Action Purpose Step 3 telemetry ietf subscription id Example: Device(config)# telemetry ietf subscription 101 Creates a telemetry subscription and enters telemetry-subscription mode. Step 4 receiver-type protocol Example: Device(config-mdt-subs)# receiver-type protocol Configures a protocol-type receiver. Step 5 receiver name name Example: Device(config-mdt-subs)# receiver name receiver1 Configures a name for the receiver for notifications. Step 6 end Example:

Device(config-mdt-subs)# end Exits telemetry telemetry-subscription mode and returns to privileged EXEC mode.

Standard/RFC Title Custom Subscription to Event Notifications draft-ietf-netconf-subscribed-notifications-03 https://tools.ietf.org/id/ draft-ietf-netconf-subscribed-notifications-03.txt NETCONF Support for Event Notifications draft-ietf-netconf-netconf-event-notifications-01 RFC 5277 NETCONF Event Notifications RFC 6241 Network Configuration Protocol (NETCONF) RFC 7950 The YANG 1.1 Data Modeling Language RFC 8040 RESTCONF Protocol RFC 8641 Subscription to YANG Notifications for Datastore Update Subscribing to Event Notifications draft-ietf-netconf-rfc5277bis-01 Subscribing to YANG Datastore Push Updates draft-ietf-netconf-yang-push-04 Subscribing to YANG datastore push updates draft-ietf-netconf-yang-push-07 https://tools.ietf.org/id/ draft-ietf-netconf-yang-push-07.txt Model-Driven Telemetry 50